
Change Cursor Help Index

Select one of sections below by clicking on it with the left mouse button or by using the Tab key to move 
the highlight and pressing Enter.

For information on how to use Help, press F1 or choose Using Help from the Help menu.

Getting Started
Editing
Manipulating the Cursor
Configuring
Working With Files
How the Cursor Works
How to Register



How to Register

Change Cursor is distributed as shareware.    It is not free.    You may use it for 21 days before registering.

Registration costs $35 (US).    Canadian currency is not acceptable.    Foreign customers please use an 
international money order or a check drawn on a US bank.    You can print a registration form, or if you 
don't have a printer, you can just write a letter giving your name and address, and say you are registering 
Change Cursor version 2.10.    Send it with a check made to Cornfield Computing to the following 
address:

Cornfield Computing
Attn: Registration Department
410 Hilltop Road
Champaign, IL 61821-7328

By registering, you support shareware development and affordable Windows software.    Your contribution 
will help promote future shareware development and the development of future versions of this program.

When you register, you will get a registration number which will allow you to hide the program's icon if you
want to.    You will also receive the next version when it becomes available.

Site licenses and product bundles are also available.    Please write for information.

Cornfield Computing also writes custom Windows applications.    Please write to the above address or fax 
to (217) 352-2027.



Getting Started

Change Cursor really performs several functions.    First, it provides a cursor editor for you to design your 
own cursors.    Second, it gives you a way to replace the normal arrow, hourglass, and "I-beam" cursors 
with your own.    Lastly, it gives you the option of enlarging the sizing arrows that appear when you are 
resizing a window.

The program provides a way for you to    configure it so that it will remember which cursors you want to 
use and automatically load them every time you start Windows.

If you use this program, please register it so that the author can continue to develop this and other 
utilities.



Editing Index

These are the topics dealing directly with editing and creating cursors.

Selecting Colors
Drawing
Seeing How the Cursor Will Look
Moving the hotspot
Undoing an edit
Using the Clipboard



Selecting Colors

There are four colors available for drawing the cursor.    Two of these are not colors in the normal sense, 
but really artifacts due to how the cursor is drawn.

Two of these colors, black and white, are self-explanatory.    These colors will always appear the same 
way on any background.    They will appear normally in the detail window.

The other colors are "screen" and "inverse."    The screen color allows whatever is behind the cursor to 
show through.    It appears blue in the detail window.

The inverse color will invert whatever color is on the screen behind it.    The exact effect will depend on 
what kind of graphics adapter you have.    The inverse color appears yellow in the detail window.

The right and left mouse buttons can correspond to different colors (see Drawing).    You select the color 
by clicking on the appropriate button in the boxes between the detail window and preview window.    The 
top set selects the color for the left button, and the bottom set selects for the right button.

NOTE: if you are using a gray-scale monitor, "inverse" appears light gray and "screen" appears dark gray.



Drawing

Drawing is done in the detail window, which appears towards the left of the Change Cursor program 
window.    It shows a blow-up of the cursor you are currently editing.    It also shows the cursor's hotspot as
a cross in one of the squares.

You can edit the cursor there by clicking on squares with the right or left mouse buttons.    You can also 
click and drag to change a series of squares.

The colors which the buttons correspond to can be changed by the color selection.    You can see how the
cursor will look at any particular time by moving the cursor to the preview window, or by examining the 
display below the color selection panels.



Previewing the Cursor

Sometimes it is difficult to predict what the cursor will look like against different background colors.    The 
preview window is provided for just this purpose.

When you move the cursor to the preview window, which is at the right side of the Change Cursor 
program window, it will change to the one you are editing.    You can move it around the window to see 
what it looks like against the different backgrounds.

Note that if the cursor you are editing is blank, it will disappear in the preview window.    To let you know 
the cursor is there, the border of the window will change color when the cursor is inside it.

An actual-size drawing of the cursor is also always shown to the right of the detail window.



Setting the Hotspot

The hot spot defines where the cursor is actually pointing.    It is shown in the detail window as a cross 
over one of the squares.    This spot can be anywhere inside the 32x32 cursor area.

To set it, choose "Set hotspot" from the "Cursor" menu.    Click on the detail window where you want the 
hotspot to be.    Clicking anywhere else will cancel the operation.



Undoing an Edit

You can undo the last thing you've done to the cursor by selecting the "Undo" option from the "Edit" 
menu.    If you have been drawing, this will restore how the cursor was before the last time you drew on it.

If the last thing you did was paste from the clipboard, then undoing will restore the cursor to what it was 
before pasting.



Using the Clipboard

You can transfer images between Change Cursor and other programs by using Windows' clipboard.

To copy the cursor you are currently editing to the clipboard, select "Copy" from the "Edit" menu.

To paste the image in the clipboard into the cursor image, select "Paste" from the "Edit" menu.    If the 
image in the clipboard is of a different size than 32x32, it will be stretched or shrunk to fit properly.    The 
colors in the image will be matched to the closest ones that Change Cursor uses.    If you don't like the 
way the cursor looks after pasting, you can undo the operation.

NOTE: If you use the Paintbrush program which comes with Windows to draw cursors, you may run into a bug 
in that program.    Paintbrush will not let you copy the entire image to the clipboard.    You will acheive best 
results by making your Paintbrush image 33x33, and drawing in the upper 32x32 part of the image.    Then, if 
you try to select the whole image, you will get the 32x32 area you need.



Configuration Index

These are the topics dealing directly with configuring Change Cursor.

Saving the Cursor Settings
Loading the Cursor Settings
Hiding the Icon



Saving the Cursor Settings

After you set the cursors to your own, you can save these settings to be loaded later.    You can then 
restore them later.

Simply choose "Save cursor settings..." from the "Configure" menu.    The names of the files which 
correspond to the cursors you are currently using will be saved.    If you enlarged the sizing arrows, the 
size you chose will also be saved.

NOTE:    The settings will only be saved correctly if the cursors you have used had corresponding filenames.



Loading the Cursor Settings

After you have saved cursor settings, you can restore them by selecting "Load cursor settings" from the 
"Configure" menu.

Doing this will read in the saved filenames, and automatically load and use the corresponding cursors.    If 
you have no saved settings, the default cursors will be used.    If you saved the settings after enlarging the
sizing arrows, the will be returned to the size you chose when you load the cursor settings.

NOTE: This action will be done automatically when you start Windows if you install Change Cursor.



Hiding the Icon

If you don't like seeing the program's icon when you aren't using it, you may choose to make it invisible.    
Selecting "Hide Icon" from the "Configure" menu will toggle this option.

When this option is selected, as indicated by a check mark, the icon will disappear when you minimize the
program, or if you start Change Cursor automatically.    If you need to restore the window, you can do so 
by running the program again from the Program Manager or the File Manager.    Rather than starting a 
second copy of Change Cursor, it will make the existing one visible again.

NOTE: This option cannot be enabled until after you register the progam.



Installation Index

These are the topics dealing directly with installing Change Cursor.

Installing Change Cursor
Uninstalling Change Cursor
Printing the Registration Form
Entering Your Registration Number



Installing Change Cursor

You can install Change Cursor so that it will run automatically each time you run Windows.    It will 
automatically load the saved settings for the cursors.

Choose "Install for automatic setup..." from the "Installation" menu.    Your WIN.INI file will be modified 
appropriately.



Uninstalling Change Cursor

If, after installing Change Cursor you decide you don't like it, or if you choose not to register, you can 
uninstall the program.

Choose "Uninstall Change Cursor" from the "Installation" menu.    Your WIN.INI file will be modified 
appropriately.



Printing the Registration Form

To make registering the program easier on you, you can print out a form on which to fill out all the 
necessary information.    Just selection "Print Registration Form" from the "Installation" menu.    The form 
will be printed on your default printer.



Entering Your Registration Number

Your registration number is on the confirmation letter you received after sending in your registration.    
Select "Register..." from the "Installation" menu.    The program will prompt you for your name and 
registration number.    Be sure to enter your name and number exactly as they appear on the letter.

After you finish, you will be a fully registered user.    You can confirm this by selecting "About Change 
Cursor..." from the "Help" menu.    It should report that it is registered to you.    You may also now use the 
"Hide Icon" option.



Manipulating Index

These are the topics dealing directly with manipulating the cursors.

Replacing the arrow
Replacing the hourglass
Replacing the I-Beam
Getting the default cursors
Changing the sizing arrows



Replacing the arrow

Once you have designed or loaded a cursor, you can use it to replace the default arrow.

Choose "Use this cursor as arrow" from the "Cursor" menu.    The cursor which is currently in the detail 
window will replace the default arrow.



Replacing the hourglass

Once you have designed or loaded a cursor, you can use it to replace the default arrow.

Choose "Use this cursor as hourglass" from the "Cursor" menu.    The cursor which is currently in the 
detail window will replace the default hourglass.



Replacing the I-Beam

Once you have designed or loaded a cursor, you can use it to replace the default I-Beam cursor.    This is 
the cursor which is shown when you are in a window which allows editing of text.

Choose "Use this cursor as I-Beam" from the "Cursor" menu.    The cursor which is currently in the detail 
window will replace the default IBeam.



Getting Default Cursors

If you want to edit or use the default arrow, hourglass, or Ibeam cursors, you can get them into the detail 
window.

Choose "Get default arrow", "Get default hourglass", or "Get default I-beam" options from the "Cursor" 
menu.



File Index

These are the topics dealing directly with working with cursor files.

Loading Files
Saving Files
Staring a New Cursor



Loading Files

You can load a cursor file as you would in any other windows application.    Just select "Open..." from the 
"File" menu.    A dialog box will appear showing you a choice of files.



Saving Files

You can load a cursor file as you would in any other windows application.    Just select "Save" or "Save 
as..." from the "File" menu.    A dialog box will appear showing you a choice of files.

"Save" will overwrite the file you have been working with.    "Save as..." will prompt you for a new file 
name.



Staring a New Cursor

If you want to start a cursor from scratch, select "New" from the "File" menu.    You will start over with a 
completely blank cursor.



Enlarging the Sizing Arrows

The sizing arrows are the double-headed cursors displayed when you are positioned along the border of 
a window.    There are four different sizing arrows:    horizontal, vertical, and the two diagonals.    You can 
choose from three different sizes of sizing arrows by choosing from the "Sizing" menu.    The "Normal" 
size is the same size that Windows uses by default.



How the cursor works

This section describes how the cursor is actually shown.    It is provided for the curious, and is not 
necessary to use Change Cursor.    It also assumes some basic knowledge of computer science.

The cursor is made up of two bitmaps, an AND bitmap, and an XOR bitmap.    Each of these is effectively 
a "monochrome" bitmap, made up of 0's and 1's.

When the cursor is displayed, a series of operations is carried out on each of the pixels in the cursor's 
32x32 pixel area.    First, each pixel is ANDed with the corresponding bit in the AND mask.    This results in
the pixel either being the original color, if the AND mask was 1, or black, if the AND mask was 0.

Now each pixel is XORed with a bit from the XOR mask.    If the bit in the mask is 0, the pixel is 
unchanged.    If the bit is 1, the pixel is inverted.

You can see that white is produced by setting the AND mask to 0, producing black, then setting the XOR 
mask to 1, inverting the black to white.    Black results when both masks are 0.    Having both masks 1 
would invert the screen color.    Lastly, having and AND mask 1 with the XOR mask 0 leaves the 
underlying screen color unchanged, or making that pixel of the cursor appear "transparent."

For most graphics cards, all this pixel manipulation actually takes place in screen memory.    Every time 
you move the cursor, the area where the cursor was is restored from memory, the new area is stored in 
memory, and the cursor is drawn.    If Windows attempts to draw where the cursor is, the cursor must be 
removed from the screen temporarily.    On some cards, the cursor is actually generated in hardware and 
is not part of screen memory.


